Visit our Twitter feed for more great content
AHExp

The 100 Forum

Wizard Cooling Aluminum Radiators

Moss Motors
AutoShrine Sponsor
AutoShrine Sponsor
AutoShrine Sponsor
AutoShrine Sponsor

gramos Avatar
gramos Graham Foster
Kefalonia, Greece   GRC
I fitted an ali rad and have been very pleased with it , I bought it from a UK manufacturer and it was made for a Ford RS 2000 and they modified the bottom hose position
to suit the 100 bottom hose , no problem .
They also offered 3 different thicknesses. I went for the 55mm core

To resolve the temp sensor issue I bought an adapter which fits into the top hose , very simple , I ended up with 2 ! if you want one let me know .

and I too thoroughly cleaned out the block and fetched a large amount of rust scale from inside , it just kept coming out !

She now runs at 170 and there was a significant weight saving with the ali rad .

. Hide banner ads & support this website by becoming a > Gold Supporting Member <
gramos Avatar
gramos Graham Foster
Kefalonia, Greece   GRC
here a picture of the sender fitted in to the top hose , the rad , by the way , was £130 from Coventry radiators


Attachments:
IMG_20180512_192845.jpg    33.6 KB
IMG_20180512_192845.jpg

IMG_20161126_152225.jpg    46.1 KB
Sign In or Register to view this photo
Luegolover Avatar
Luegolover Steve L
London, London, UK   GBR
Hello Graham,

That would be a very sensible solution, I could just bung the current outlet and fit the new one. I'll see what the supplier comes back to me with but I suspect I'll be pinging you a message about the second adapter in a few days. I see that the picture was taken a few years back so I hope you still have it and can find it as that would be a challenge for me!

Steve

. Hide banner ads & support this website by becoming a > Gold Supporting Member <
gramos Avatar
gramos Graham Foster
Kefalonia, Greece   GRC
Steve , no worries , I saw it the other day in the garage , still in the box !

strange coincidence today ,
just returned from first long run after rebuilding my engine and the water temp is not reading !

may have ruptured the capillary pipe , looks ok but may have a crack somewhere .

sliproc Avatar
sliproc Kevin Quistberg E
Long Beach, CA, USA   USA
This is why I only buy Chinese auto parts when all other options have been exhausted. Why put cheap Chinese parts in you classic(and expensive)beauty just to save a couple of bucks. And don't get me started about their wheel bearings.

. Hide banner ads & support this website by becoming a > Gold Supporting Member <

To add your reply, or post your own questions




Registration is FREE and takes less than a minute!


Having trouble posting or changing forum settings?
Read the Forum Help (FAQ) or contact the webmaster





Join The Club

Sign in to ask questions, share photos, and access all website features

Your Cars

1959 Austin Healey Sprite

Text Size

Larger Smaller
Reset Save

Sponsor Links